$re = '/^[^,]*,(?!\d{9}(?:[xv]|\d{3}))[^,]+,/mi';
$str = 'foo,666666666v,bar
foo,123456789012,bar
,nope,bar';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);