using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^,]*,(?!\d{9}(?:[xv]|\d{3}))[^,]+,";
string input = @"foo,666666666v,bar
foo,123456789012,bar
,nope,bar";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}