using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/[^/]*?((?:\/[^/]*?){2})";
string input = @"https://yoursite/top-news/post-2023-03-17-182258/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}