const regex = /^https?:\/\/[^/]*?((?:\/[^/]*?){2})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/[^\/]*?((?:\\\/[^\/]*?){2})', '')
const str = `https://yoursite/top-news/post-2023-03-17-182258/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}