import Foundation
let pattern = #"^https?:\/\/[^/]*?((?:\/[^/]*?){2})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://yoursite/top-news/post-2023-03-17-182258/"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}