package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^https?:\/\/[^/]*?((?:\/[^/]*?){2})`)
var str = `https://yoursite/top-news/post-2023-03-17-182258/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}