import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d{8})((?:0*)(\\d\\{,8\\}))(?=\\d{8})";
final String string = "112233441234567855667788 --> 12345678\n"
+ "112233440012345655667788 --> 123456\n"
+ "112233001234567855667788 --> 12345678\n"
+ "112233000012345655667788 --> 123456";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}