import re
regex = re.compile(r"(?<=\d{8})((?:0*)(\d{,8}))(?=\d{8})")
test_str = ("112233441234567855667788 --> 12345678\n"
"112233440012345655667788 --> 123456\n"
"112233001234567855667788 --> 12345678\n"
"112233000012345655667788 --> 123456")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")