#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[A-Z][a-z]{2,}_[A-Z][a-z]{2,})"
Local $sString = "Firstname_Lastname" & @CRLF & _
"fi_na" & @CRLF & _
"Fi_na" & @CRLF & _
"fi_Na" & @CRLF & _
"Fir_Name" & @CRLF & _
"Firs_name" & @CRLF & _
"firs_Name"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")