package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^[A-Z][a-z]{2,}_[A-Z][a-z]{2,})`)
var str = `Firstname_Lastname
fi_na
Fi_na
fi_Na
Fir_Name
Firs_name
firs_Name`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}