import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[A-Z][a-z]{2,}_[A-Z][a-z]{2,})";
final String string = "Firstname_Lastname\n"
+ "fi_na\n"
+ "Fi_na\n"
+ "fi_Na\n"
+ "Fir_Name\n"
+ "Firs_name\n"
+ "firs_Name";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}