$re = '/(^[A-Z][a-z]{2,}_[A-Z][a-z]{2,})/m';
$str = 'Firstname_Lastname
fi_na
Fi_na
fi_Na
Fir_Name
Firs_name
firs_Name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);