using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+?[0-9()\s-]{8,25}[0-9]$";
string input = @"+123456789
+1 234 567 8910
1 (234) 567 8910
1 (234) 567-8910
+1-234-567-8910
1 234 567 8910
""123456789""
'123456789'
/123456789/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}