package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+?[0-9()\s-]{8,25}[0-9]$`)
var str = `+123456789
+1 234 567 8910
1 (234) 567 8910
1 (234) 567-8910
+1-234-567-8910
1 234 567 8910
"123456789"
'123456789'
/123456789/
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}