// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+?[0-9()\s-]{8,25}[0-9]$").unwrap();
let string = "+123456789
+1 234 567 8910
1 (234) 567 8910
1 (234) 567-8910
+1-234-567-8910
1 234 567 8910
\"123456789\"
'123456789'
/123456789/
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}