import re
regex = re.compile(r"/[^/]+$", flags=re.MULTILINE)
test_str = "https://abc.xyz/f/b/go_cc_Jpterxvid_avi_mp4"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)