const regex = /[^\w]+/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\w]+', 'gu')
const str = `➜🚀🚀🚀➜ 🎣 это 🎣🎣 запрос 🚀 для 🎣🎣 поиска`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);