use strict;
my $str = '➜🚀🚀🚀➜ 🎣 это 🎣🎣 запрос 🚀 для 🎣🎣 поиска';
my $regex = qr/[^\w]+/up;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";