#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/item\/(?!page\/).+"
Local $sString = "https://example.com/item/" & @CRLF & _
"https://example.com/item/page/2/?wpv_view_count=258" & @CRLF & _
"https://example.com/item/page/3/?wpv_view_count=258" & @CRLF & _
"https://example.com/item/snv00001-indice-di-documenti/" & @CRLF & _
"https://example.com/item/sa00068-libro/" & @CRLF & _
"https://example.com/item/aud00068-audio/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")