re = /\/item\/(?!page\/).+/m
str = 'https://example.com/item/
https://example.com/item/page/2/?wpv_view_count=258
https://example.com/item/page/3/?wpv_view_count=258
https://example.com/item/snv00001-indice-di-documenti/
https://example.com/item/sa00068-libro/
https://example.com/item/aud00068-audio/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end