using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/item\/(?!page\/).+";
string input = @"https://example.com/item/
https://example.com/item/page/2/?wpv_view_count=258
https://example.com/item/page/3/?wpv_view_count=258
https://example.com/item/snv00001-indice-di-documenti/
https://example.com/item/sa00068-libro/
https://example.com/item/aud00068-audio/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}