using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"public\s+(.+):([^,]+),?";
string substitution = @"this.$1 = $1;";
string input = @"
public typeface:Typeface,
public weight:FontWeight,
public color:Color,
public size:Units,
public line:Units,
public character:Units,
public fontStyle:ABoolean,
public decorationUnderline:ABoolean,
public decorationCrossed:ABoolean,
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}