$re = '/public\s+(.+):([^,]+),?/';
$str = '
public typeface:Typeface,
public weight:FontWeight,
public color:Color,
public size:Units,
public line:Units,
public character:Units,
public fontStyle:ABoolean,
public decorationUnderline:ABoolean,
public decorationCrossed:ABoolean,
';
$subst = "this.$1 = $1;";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;