// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"public\s+(.+):([^,]+),?").unwrap();
let string = "
public typeface:Typeface,
public weight:FontWeight,
public color:Color,
public size:Units,
public line:Units,
public character:Units,
public fontStyle:ABoolean,
public decorationUnderline:ABoolean,
public decorationCrossed:ABoolean,
";
let substitution = "this.$1 = $1;";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}