import re
regex = re.compile(r"public\s+(.+):([^,]+),?")
test_str = ("\n"
" public typeface:Typeface,\n"
" public weight:FontWeight,\n"
" public color:Color,\n"
" public size:Units,\n"
" public line:Units,\n"
" public character:Units,\n"
" public fontStyle:ABoolean,\n"
" public decorationUnderline:ABoolean,\n"
" public decorationCrossed:ABoolean,\n"
" ")
subst = "this.$1 = $1;"
result = regex.sub(subst, test_str)
if result:
print(result)