#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ix)^(?<weekdays>" & @CRLF & _
" ( " & @CRLF & _
" \b" & @CRLF & _
" (?<weeks>mon|tue|wed|thu|fri|sat|sun)" & @CRLF & _
" (?:\.\.(?&weeks))?" & @CRLF & _
" ,?" & @CRLF & _
" )+" & @CRLF & _
")$"
Local $sString = "mon,mon..tue"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")