using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<weekdays>
(
\b
(?<weeks>mon|tue|wed|thu|fri|sat|sun)
(?:\.\.(?&weeks))?
,?
)+
)$";
string input = @"mon,mon..tue";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}