import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<weekdays>\n"
+ " ( \n"
+ " \\b\n"
+ " (?<weeks>mon|tue|wed|thu|fri|sat|sun)\n"
+ " (?:\\.\\.(?&weeks))?\n"
+ " ,?\n"
+ " )+\n"
+ ")$";
final String string = "mon,mon..tue";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}