const regex = /^(?<weekdays>
(
\b
(?<weeks>mon|tue|wed|thu|fri|sat|sun)
(?:\.\.(?&weeks))?
,?
)+
)$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<weekdays>
(
\\b
(?<weeks>mon|tue|wed|thu|fri|sat|sun)
(?:\\.\\.(?&weeks))?
,?
)+
)$', 'i')
const str = `mon,mon..tue`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}