#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)https?:\/\/(?:www\.)?([a-z]+).*"
Local $sString = "http://www.mywebsiteameW1234.com" & @CRLF & _
"https://www.mywebsiteameW1234.com" & @CRLF & _
"http://mywebsiteameW1234.com" & @CRLF & _
"https://mywebsiteameW1234.com"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)