import Foundation
let pattern = #"https?:\/\/(?:www\.)?([a-z]+).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.mywebsiteameW1234.com
https://www.mywebsiteameW1234.com
http://mywebsiteameW1234.com
https://mywebsiteameW1234.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)