import re
regex = re.compile(r"https?:\/\/(?:www\.)?([a-z]+).*", flags=re.MULTILINE)
test_str = ("http://www.mywebsiteameW1234.com\n"
"https://www.mywebsiteameW1234.com\n"
"http://mywebsiteameW1234.com\n"
"https://mywebsiteameW1234.com")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)