re = /https?:\/\/(?:www\.)?([a-z]+).*/m
str = 'http://www.mywebsiteameW1234.com
https://www.mywebsiteameW1234.com
http://mywebsiteameW1234.com
https://mywebsiteameW1234.com'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result