using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^202[01][0-9]{4}abc\.(?:dat|csv)$";
string input = @"01990205abc.dat
20200304abc.dat
20210506abc.csv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}