re = /^202[01][0-9]{4}abc\.(?:dat|csv)$/m
str = '01990205abc.dat
20200304abc.dat
20210506abc.csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end