const regex = /^202[01][0-9]{4}abc\.(?:dat|csv)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^202[01][0-9]{4}abc\\.(?:dat|csv)$', 'gm')
const str = `01990205abc.dat
20200304abc.dat
20210506abc.csv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}