package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^202[01][0-9]{4}abc\.(?:dat|csv)$`)
var str = `01990205abc.dat
20200304abc.dat
20210506abc.csv`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}