package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\s+(?:n$)?`)
var str = `j o h n`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}