use strict;
my $str = 'j o h n';
my $regex = qr/\s+(?:n$)?/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";