import Foundation
let pattern = #"\s+(?:n$)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"j o h n"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)