#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(?:stackoverflow\.com)?[\/]*([cv|users|story]?[\/\w\-\.]*)$)|(^(?:http?:\/\/|https?:\/\/)?(?:www\.)?stackoverflow\.com\/(?:\/*)([\w\-\.\/\%]*))"
Local $sString = "stackoverflow.com/story/razvan-ciocanel" & @CRLF & _
"cv/jmwicks" & @CRLF & _
"http://stackoverflow.com/cv/razvan-ciocanel" & @CRLF & _
"http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel?tab=profile" & @CRLF & _
"http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel" & @CRLF & _
"http://stackoverflow.com/story/razvan-ciocanel" & @CRLF & _
"stackoverflow.com/story/razvan-ciocanel" & @CRLF & _
"/story/razvan-ciocanel" & @CRLF & _
"users/2141313/jmwicks" & @CRLF & _
"users/2141313/jmwicks/" & @CRLF & _
"/users/2141313/jmwicks" & @CRLF & _
"/users/2141313/jmwicks/" & @CRLF & _
"cv/jmwicks" & @CRLF & _
"/cv/jmwicks" & @CRLF & _
"/cv/jmwicks/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")