# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^(?:stackoverflow\.com)?[\/]*([cv|users|story]?[\/\w\-\.]*)$)|(^(?:http?:\/\/|https?:\/\/)?(?:www\.)?stackoverflow\.com\/(?:\/*)([\w\-\.\/\%]*))"
test_str = ("stackoverflow.com/story/razvan-ciocanel\n"
"cv/jmwicks\n"
"http://stackoverflow.com/cv/razvan-ciocanel\n"
"http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel?tab=profile\n"
"http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel\n"
"http://stackoverflow.com/story/razvan-ciocanel\n"
"stackoverflow.com/story/razvan-ciocanel\n"
"/story/razvan-ciocanel\n"
"users/2141313/jmwicks\n"
"users/2141313/jmwicks/\n"
"/users/2141313/jmwicks\n"
"/users/2141313/jmwicks/\n"
"cv/jmwicks\n"
"/cv/jmwicks\n"
"/cv/jmwicks/\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.