using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^(?:stackoverflow\.com)?[\/]*([cv|users|story]?[\/\w\-\.]*)$)|(^(?:http?:\/\/|https?:\/\/)?(?:www\.)?stackoverflow\.com\/(?:\/*)([\w\-\.\/\%]*))";
string input = @"stackoverflow.com/story/razvan-ciocanel
cv/jmwicks
http://stackoverflow.com/cv/razvan-ciocanel
http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel?tab=profile
http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel
http://stackoverflow.com/story/razvan-ciocanel
stackoverflow.com/story/razvan-ciocanel
/story/razvan-ciocanel
users/2141313/jmwicks
users/2141313/jmwicks/
/users/2141313/jmwicks
/users/2141313/jmwicks/
cv/jmwicks
/cv/jmwicks
/cv/jmwicks/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}