// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^(?:stackoverflow\.com)?[\/]*([cv|users|story]?[\/\w\-\.]*)$)|(^(?:http?:\/\/|https?:\/\/)?(?:www\.)?stackoverflow\.com\/(?:\/*)([\w\-\.\/\%]*))").unwrap();
let string = "stackoverflow.com/story/razvan-ciocanel
cv/jmwicks
http://stackoverflow.com/cv/razvan-ciocanel
http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel?tab=profile
http://stackoverflow.com/users/759476/r%C4%83zvan-cioc%C4%83nel
http://stackoverflow.com/story/razvan-ciocanel
stackoverflow.com/story/razvan-ciocanel
/story/razvan-ciocanel
users/2141313/jmwicks
users/2141313/jmwicks/
/users/2141313/jmwicks
/users/2141313/jmwicks/
cv/jmwicks
/cv/jmwicks
/cv/jmwicks/
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}