#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^<img src="index-(?![12]_)(\d+)_\d+\.(?:jpg|png)"\/><br>$"
Local $sString = "<img src="index-1_2.jpg"/><br>" & @CRLF & _
"<img src="index-1_3.jpg"/><br>" & @CRLF & _
"<img src="index-1_5.jpg"/><br>" & @CRLF & _
"<img src="index-2_1.jpg"/><br>" & @CRLF & _
"<img src="index-2_5.jpg"/><br>" & @CRLF & _
"<img src="index-3_1.png"/><br>" & @CRLF & _
"<img src="index-23_8.png"/><br>" & @CRLF & _
"<img src="index-22_9.png"/><br>" & @CRLF & _
"<img src="index-22_1.jpg"/><br>" & @CRLF & _
"<img src="index-22_2.jpg"/><br>" & @CRLF & _
"<img src="index-99_5.png"/><br>" & @CRLF & _
"<img src="index-100_5.png"/><br>" & @CRLF & _
"<img src="index-1000_5.png"/><br>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)