const regex = /^<img src="index-(?![12]_)(\d+)_\d+\.(?:jpg|png)"\/><br>$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^<img src="index-(?![12]_)(\\d+)_\\d+\\.(?:jpg|png)"\\\/><br>$', 'gm')
const str = `<img src="index-1_2.jpg"/><br>
<img src="index-1_3.jpg"/><br>
<img src="index-1_5.jpg"/><br>
<img src="index-2_1.jpg"/><br>
<img src="index-2_5.jpg"/><br>
<img src="index-3_1.png"/><br>
<img src="index-23_8.png"/><br>
<img src="index-22_9.png"/><br>
<img src="index-22_1.jpg"/><br>
<img src="index-22_2.jpg"/><br>
<img src="index-99_5.png"/><br>
<img src="index-100_5.png"/><br>
<img src="index-1000_5.png"/><br>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);