import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<img src=\"index-(?![12]_)(\\d+)_\\d+\\.(?:jpg|png)\"\\/><br>$";
final String string = "<img src=\"index-1_2.jpg\"/><br>\n"
+ "<img src=\"index-1_3.jpg\"/><br>\n"
+ "<img src=\"index-1_5.jpg\"/><br>\n"
+ "<img src=\"index-2_1.jpg\"/><br>\n"
+ "<img src=\"index-2_5.jpg\"/><br>\n"
+ "<img src=\"index-3_1.png\"/><br>\n"
+ "<img src=\"index-23_8.png\"/><br>\n"
+ "<img src=\"index-22_9.png\"/><br>\n"
+ "<img src=\"index-22_1.jpg\"/><br>\n"
+ "<img src=\"index-22_2.jpg\"/><br>\n"
+ "<img src=\"index-99_5.png\"/><br>\n"
+ "<img src=\"index-100_5.png\"/><br>\n"
+ "<img src=\"index-1000_5.png\"/><br>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}