using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<img src=""index-(?![12]_)(\d+)_\d+\.(?:jpg|png)""\/><br>$";
string substitution = @"$1";
string input = @"<img src=""index-1_2.jpg""/><br>
<img src=""index-1_3.jpg""/><br>
<img src=""index-1_5.jpg""/><br>
<img src=""index-2_1.jpg""/><br>
<img src=""index-2_5.jpg""/><br>
<img src=""index-3_1.png""/><br>
<img src=""index-23_8.png""/><br>
<img src=""index-22_9.png""/><br>
<img src=""index-22_1.jpg""/><br>
<img src=""index-22_2.jpg""/><br>
<img src=""index-99_5.png""/><br>
<img src=""index-100_5.png""/><br>
<img src=""index-1000_5.png""/><br>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}