package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[^\d$]|^)(\d+)`)
var str = `2 burgers and 3 drinks would be $15
The cost of 2 burgers and 3 drinks are $15 test12test
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}