re = /(?:[^\d$]|^)(\d+)/m
str = '2 burgers and 3 drinks would be $15
The cost of 2 burgers and 3 drinks are $15 test12test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end